Announcement

Collapse
No announcement yet.

Lost my FT emblem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lost my FT emblem

    Hi, when i connect this morning and went to get my daily gold from Wendy, i saw that i lost my emblem. It's hasn't been 90 days yet and i know that because i always save 1888 gold at least to buy the next one. I have 1306 gold now so i know it's a bug (coincidence with new year?). Sans titre.png

  • #2
    Same here. I can check my transactions on my card, but I think I only bought S-class for the second time about 30 or 45 days ago.

    Comment


    • #3
      Same here. Lost 80 days of S-Class...

      Comment


      • #4
        I have lost mine too...

        Comment


        • #5
          Three days since the first support ticket, still no refund, correction or even a fucking reply, besides the (probably automated) "we've gotten your complaint"!
          Gotta love this level of customer support...

          Comment


          • #6
            I dont think we even get refund after this bug.

            Comment


            • #7
              I have lost mine aswell

              Comment


              • #8
                I lost mine as well on the first of January. I still had 20 days of S-class. Customer support reply was: "Thank you for bringing this to our attention.
                We have already notified our team regarding this issue. Kindly allow them time to check and fix this issue. On that note, we do apologize for the troubles that you experienced.
                I would like to ask for your patience in waiting for its resolution."

                Comment


                • #9
                  Well, got compensated. Still think it was a bit slow, but I'm satisfied.

                  Comment


                  • #10
                    2 week since i post this and i got no refund and no message from the staff. can someone give us an answer?

                    Comment

                    Working...
                    X